Попытка эксплуатации уязвимости WordPress через upl.php
Попытка эксплуатации уязвимости WordPress через upl.php
Категория: Разработка Теги: Уязвимости Опубликовано: 22 апреля 2023

Что за атака GET /upl.php HTTP/1.1?

Начнем с того, что я нашел в логе nginx такую запись (IP-адреса изменены, сайт не этот):

2023/03/13 08:47:55 [error] 2615030#2615030: *16811 open() "/usr/share/nginx/html/upl.php" failed (2: No such file or directory), client: 157.245.73.200, server: localhost, request: "GET /upl.php HTTP/1.1", host: "10.232.91.44"

Что пытался сделать злоумышленник? 

Безусловно, этот запрос направлен не вручную, а из специальной программы или подготовленного скрипта / бота, но управляет этим человек, поэтому для упрощения я буду говорить именно про этого злоумышленника.

Разберём HTTP-запрос

IP-адрес 10.232.91.44 это адрес нашего веб-сервера и то, что тут написан именно IP-адрес и localhost, а не доменное имя говорит о том, что злоумышленник в HTTP-запросе писал именно IP-адрес с указанием server: localhost, а не конкретный сайт.

Строка failed (2: No such file or directory) говорит о том, что запрашиваемый файл не существует и соответственно ему вернулся статус 404. На самом деле, сам по себе статус 404 не означает, что вектор атаки не сработал - тут нужно повторить запрос и посмотреть, не добавилось ли что-то лишнее в запрос, а в случае со слепыми XSS (Blind XSS) вектор атаки может сработать не в том месте, где ввели команду.

IP-адрес злоумышленника 157.245.73.200 и он принадлежит хостинг-провайдеру DIGITALOCEAN-ASN, который находится в Северной Голландии, провинции на западе Нидерландов.

Сам запрос ""GET /upl.php HTTP/1.1" указывает на то, что злоумышленник хотел получить доступ к файлу upl.php для загрузки произвольного файла.

По данным CleanTalk с данного IP-адреса не было рассылки спама по формам на веб-сайтах, однако, в базе AbuseIPDB указано, что данного уже были атаки на другие сайты, правда всего всего 6 за последние 4 месяца.

Технические детали

Очевидно, что злоумышленник хотел проэксплуатировать уязвимость в старой версии WordPress. Эта уязвимость была обнаружена в 2013 году, поэтому легко исправляется обновлением WordPress и всех плагинов.

Для этой уязвимости в открытом доступе опубликованы эксплоиты, позволяющие загрузить произвольный файл и выполнить его на веб-сервере.

И сразу стоит отметить, что он искал этот файл не по доменному имени, а по IP-адресу сервера. Это очень умно.

Первым делом эксплоит проверяет наличие файла upl.php, а потом пытается загрузить произвольный файл командой /wp-content/themes/ThisWay/includes/uploadify/upload_settings_image.php. При успешной эксплуатации уязвимости загруженный файл можно найти по адресу /wp-content/uploads/[год]/[месяц]/[ваш_файл].php.

Далее он может выполнить данный файл на сервере.

Как защитить веб-сервер?

Немного информации

Скорее всего злоумышленник выполнял сканирование веб-приложения на наличие уязвимостей, используя инструменты для автоматического сканирования уязвимостей.

Любой админ скажет, что реагировать на такие записи в журнале не нужно, но любой опытный пентестер скажет, что реагировать на такие записи в журнале нужно!

Автоматические сканирования на наличие уязвимостей веб-серверов ботами со всего мира - это не просто неприятное явление, но и серьезная угроза для безопасности веб-сервера. Согласно отчету, опубликованному в 2019 году, боты составляют около 37,2% всего трафика Интернета, и это число продолжает расти. Боты, сканирующие веб-серверы, могут искать уязвимости, которые можно использовать для получения несанкционированного доступа к серверу или к данным, которые он содержит.

Теперь скажите честно, последней ли версии у вас всё ПО и библиотеки как на веб-сервере, так и в самом сайте? Уверен, что у большинства будут далеко не последние версии, так как при обновлении много придется настраивать заново. Пора задуматься и понять, что риск не равен нулю.

С чего начинается атака хакера или пентестера на веб-сервер? 

Первым этапом является именно OSINT, но если упростить, то сначала ему нужно собрать информацию. Все прочие виды атак мы опустим, так как тут речь идет о конкретной. В данном случае, злоумышленник собирает информацию о сайте и сервере из открытых источников.

Далее через кучу прокси-серверов сканирует сервер на наличие уязвимостей. При таком сканировании на сервер отправляет множество запросов, но фишка в том, что он использует целый пул прокси-серверов, поэтому каждый 1-2 запроса выполняются с разных IP-адресов. Однако, при частых сканированиях они все будут присутствовать в спам базах.

Если его сканер найдет уязвимость, тогда злоумышленник уже сам будет производить атаку, хотя некоторые так называемые сканирования выполняли через пентестерский фреймворк metasploit методом check.

Рекомендации по противодействию атакам на веб-сервер

Для защиты от автоматических сканирований наличия уязвимостей веб-серверов ботами со всего мира, рекомендуется использовать следующие технические меры защиты на nginx или apache:

  1. Установка модуля ModSecurity: ModSecurity - это модуль для HTTP-сервера Apache, который позволяет обнаруживать и предотвращать атаки на веб-приложения. Он может блокировать запросы, которые соответствуют известным атакам, а также запросы, которые слишком часто повторяются, что может указывать на сканирование.
  2. Использование Fail2ban: Fail2ban - это программное обеспечение, которое может анализировать логи веб-сервера и блокировать IP-адреса, которые слишком часто отправляют запросы на сервер. Это может предотвратить сканирование и другие виды атак на сервер.
  3. Настройка Cloudflare или его аналога: Cloudflare - это сервис, который может использоваться в качестве прокси-сервера для вашего веб-сайта. Он может блокировать запросы от известных ботов и других источников нежелательного трафика, а также предоставлять другие инструменты защиты.

Важно блокировать автоматические сканирования на наличие уязвимостей веб-серверов ботами со всего мира, чтобы защитить данные и обеспечить безопасность веб-сервера. Использование рекомендуемых технических мер защиты поможет предотвратить сканирование и другие виды атак, которые могут привести к серьезным последствиям для вашего веб-сервера.

В качестве дополнительных рекомендаций можно назвать весьма очевидные вещи:

  1. Обновлять все используемое ПО на веб-сервере до последних версий.
  2. Обновлять используемые веб-приложениями библиотеки до последних версий.
  3. Производить сканирование на наличие уязвимостей доступными средствами (в Kali Linux для этого множество инструментов).
  4. Использовать средства для аудита кода на безопасность (например, Codacy, Codeac, deepcode или SonarCloud).
  5. Отслеживать новые уязвимости в NATIONAL VULNERABILITY DATABASE и в Банке данных угроз безопасности информации.
  6. В идеале нужно установить WAF, но такие продукты очень дорогие, а бесплатные неэффективны.

Также можно рассмотреть блокировку посетителей из других стран при помощи GeoIP, но в спорных территориях могут быть неправильные определения, а также необходимо сделать исключения для пула адресов поисковых роботов Google и Bing.

Алексей Черемных
670